Report Generation Issue

When Configuring roles i gave access to Administrator Read, Group Read and Write option to a role. However any user with that role is not able to create report. I noticed that form the default users created, only Super User had these access. How to solve this as I have a role who can only read and create reports.

In order for a role to be able to create reports, they would need to have the “create” or “manage” permissions for the Role record. Unfortunately, these permissions are not currently exposed in the Admin UI. What you can do is manually add these permissions to your role in the configuration bundle file. Your role report permission definition will look something like the below.

  "resource": "report",
  "actions": [
  "role_ids": [


If you replace "manage" with "create", that should also work.

@jack.miszencin Thank you. I had tried that and it worked with create. I wanted to make sure i was not wrong and there is no other possibility from admin. Thank you