What's the Primero development setup pre-seeded username/password

Hello Primero Community,

What’s the default password for primero development setup , I tried primero /primer0! but it didn’t work.

I was able to manage the primero dev setup but password is not working for me.

Hi Jins, could you have a look at this? Problem with a preseeded admin account credentials · Issue #145 · primeroIMS/primero · GitHub

1 Like

Dear @childprotectioninnov Thanks Actually i tried the latest version Release v2.5.3 - 31 November 2022 · primeroIMS/primero · GitHub and still have this issue.

I tried mkinstall for my mac which should have installed SSL certificate for my localhost i guess. Did i miss anything?

Maybe try adding it in ruby?

Find an Agency and role. This example uses UNICEF

unicef = Agency.find_by(agency_code: 'UNICEF')
role = Role.find_by_name('Superuser')

Then add the superuser

	'user_name' => 'some_user_name',
	'password' => 'some_password',
	'password_confirmation' => 'some_password',
	'full_name' => 'My Name',
	'email' => 'me@myemail.com',
	'disabled' => 'false',
	'agency_id' => Agency.find_by(unique_id: 'UNICEF').id,
	'role_id' => Role.find_by_name('Superuser').id,
	'user_groups' => UserGroup.all,
	'locale' => Primero::Application::LOCALE_ENGLISH
1 Like

Thank you so much @irlawrence & @childprotectioninnov , I’m now able to sort this out. Noting this down incase if it helps for future users.

Because of three columns missing in system_settings table my command rails db:seed didn’t run correctly and hence no users were created which i didn’t notice till you give me a hint to create the users.

I created these columns manually, thanks for the hint in this post here

After that i re-ran rails db:seed & were able to use primero/primer0! credentials itself

1 Like